首页  »  新闻中心  »  培训分享  »  内容速览
登录商贸宝时,提示数据库(客户端、中间层)版本低,如何解决?_潍坊用友软件:133-0536-5573.
来源:本站 发布时间:2014/5/21 19:34:05 浏览量:

 【原因分析】
(1)软件打了补丁还没有进行数据升级;(2)客户端和服务器的版本不一致;比如服务器打了补丁但是客户端没有打补丁;(3)补丁和安装的程序没有安装在一起,比如程序安装到d盘而补丁打到c盘或者其它的文件夹,以致某些需要替换的文件没有更新所致。上面的情况都可能出现上面的报错。
【解决方案】
商贸宝正常连接时,涉及到三个版本比较,即商贸宝服务器文件版本、商贸宝客户端文件版本和商贸宝账套数据库版本,只有这三个版本一致的情况下,才能够正确连接:
(1)当数据库版本>服务器版本=客户端版本时,软件提示客户端版本低,此时只需要更新软件应用程序于足够高的版本就可以。
(2)当数据库版本<服务器版本=客户端版本时,软件提示数据库版本低,此时可以确定后,软件会自动引导升级(当商贸宝服装版10.2系列升级至11.0系列时,可能会提示数据类型不匹配,此时无法自动引导升级,需要使用商贸宝的系统工具进行升级操作,选择系统工具,验证SQL用户密码后,登录进入,选择数据升级。通过蓝条选择要升级的账套,在下方的文件名处选择升级文件包,文件包存放在商贸宝安装目录的服务器目录下,目录名为UPGRADE,文件名为UPGRADEDB.SQL)。
(3)当数据库版本=服务器版本<客户端版本时,软件提示中间层版本低,此时需要升级商贸宝的服务器,视情况决定是否继续升级数据库(此问题一般是由于客户端和服务器升级不同步造成的,比如客户端机器安装软件补丁,而服务器未安装;或者服务器在安装补丁的时候,没有将服务器程序退出,导致文件更新失败,同时,客户端版本和服务器版本不一致,也可能引起错误“服务器连接失败”)。

 
 

打印本页 || 关闭窗口